Breaking

Thursday 21 September 2017

Day 5: Loops

                    Day 5: Loops



Objective
In this challenge, we're going to use loops to help us do some simple math. Check out the Tutorial tab to learn more.
Task
Given an integer, , print its first  multiples. Each multiple  (where ) should be printed on a new line in the form: n x i = result.
Input Format
A single integer, .
Constraints
Output Format
Print  lines of output; each line  (where ) contains the  of  in the form:
n x i = result
Sample Input
2
Sample Output
2 x 1 = 2
2 x 2 = 4
2 x 3 = 6
2 x 4 = 8
2 x 5 = 10
2 x 6 = 12
2 x 7 = 14
2 x 8 = 16
2 x 9 = 18
2 x 10 = 20

C++:

#include <iostream>

using namespace std;

int main() {
    int N;
    cin >> N;

    for (int i = 1; i < 11; i++) {
        printf("%i x %i = %i\n", N, i, N * i);
    }

    return 0;
}


Java:

import java.util.Scanner;

public class Solution {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int N = in.nextInt();
        in.close();

        for (int i = 1; i < 11; i++) {
            System.out.println(N + " x " + i + " = " + N * i);
        }
    }
}


Python:

N = int(input())

for i in range(1, 11):
    print(str(N) + " x " + str(i) + " = " + str(N * i))

No comments:

Post a Comment

Like