Breaking

Thursday 21 September 2017

Day 7: Arrays

                   Day 7: Arrays


Objective
Today, we're learning about the Array data structure. Check out the Tutorial tab for learning materials and an instructional video!
Task
Given an array, , of  integers, print 's elements in reverse order as a single line of space-separated numbers.
Input Format
The first line contains an integer,  (the size of our array).
The second line contains  space-separated integers describing array 's elements.
Constraints
  • , where  is the  integer in the array.
Output Format
Print the elements of array  in reverse order as a single line of space-separated numbers.
Sample Input
4
1 4 3 2
Sample Output
2 3 4 1


Code:


C++:

#include <algorithm>
#include <iostream>
using namespace std;
int main() {
    int N;
    cin >> N;

    int arr[N];

    for (int i = 0; i < N; i++) {
        cin >> arr[i];
    }
    reverse(arr, arr + N);
    for (int i = 0; i < N; i++) {
        cout << arr[i] << " ";
    }

    return 0;
}


Java:

import java.util.Scanner;
public class Solution {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int n = in.nextInt();
        int[] arr = new int[n];
        for (int i = 0; i < n; i++) {
            arr[i] = in.nextInt();
        }
        for (int i = 0; i < n; i++) {
            int idx = n - i - 1;
            System.out.print(arr[idx] + " ");
        }
       in.close();   
}}

Python:

input()

arr = str(input()).split(" ")
arr.reverse()

for num in arr:
    print(num + " ", end="")


No comments:

Post a Comment

Like