Breaking

Sunday 17 September 2017

Day 3: Intro to Conditional Statements

Day 3: Intro to Conditional Statements

hackerrank Day 3: Intro to Conditional Statement in cpp, python, java


Objective
In this challenge, we're getting started with conditional statements. Check out the Tutorial tab for learning materials and an instructional video!
Task
Given an integer, , perform the following conditional actions:
  • If  is odd, print Weird
  • If  is even and in the inclusive range of  to , print Not Weird
  • If  is even and in the inclusive range of  to , print Weird
  • If  is even and greater than , print Not Weird
Complete the stub code provided in your editor to print whether or not  is weird.
Input Format
A single line containing a positive integer, .
Constraints
Output Format
Print Weird if the number is weird; otherwise, print Not Weird.
Sample Input 0
3
Sample Output 0
Weird
Sample Input 1
24
Sample Output 1
Not Weird
Explanation
Sample Case 0: 
 is odd and odd numbers are weird, so we print Weird.
Sample Case 1: 
 and  is even, so it isn't weird. Thus, we print Not Weird
Code:
Cpp:
#include <iostream>

using namespace std;

int main() {
    int N;
    cin >> N;

    if (N % 2 != 0) cout << "Weird";
    else {
        if (N <= 5) cout << "Not Weird";
        else if (N <= 20) cout << "Weird";
        else cout << "Not Weird";
    }

Java:
import java.util.Scanner;

public class Solution {
    public static void main(String[] args) {
        Scanner scan = new Scanner(System.in);
        int n = scan.nextInt();
        scan.close();

        if (n % 2 == 0) {
            if (n < 6) System.out.println("Not Weird");
            else if (n < 21) System.out.println("Weird");
            else System.out.println("Not Weird");
        } else System.out.println("Weird");
    }}


Python:


N = int(input())

if N % 2 != 0:
    print("Weird")
else:
    if N <= 5:
        print("Not Weird")
    elif N <= 20:
        print("Weird")
    else:
        print("Not Weird")
Please do comment If u have any Queries!

No comments:

Post a Comment

Like